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In this tutorial you will learn how to run Cadence and how to draw a simple schematic using 
basic components from analogLib, and then run ac simulations.  
 

1.  Connection to ECE servers  
I would recommend running the Cadence simulation from the undergraduate lab (MCLD 348 or 
358) on a wired (Ethernet) connection if you find the simulations/GUI running slow. Or if you 
have access to faster computers in your own research lab (EECE), you may use those computers 
too. 
Otherwise, you can use X2go or MobaXterm on Windows/Mac to run Cadence simulations on a 
server. X2go usually runs faster than MobaXterm.  
Note: in the following instructions, userID/username refers to your EECE user account id (not 
your CWL). 
X2go [Windows]:  
Please see instructions here: http://sudip.ece.ubc.ca/cad-access/ 
MobaXterm [Windows] 
Download from http://mobaxterm.mobatek.net/. There is a tutorial on the main page of their 
website. After installing the software use the steps shown in the following picture to setup your 
ssh connection. For the rest of this tutorial pay special attention to the highlight areas in the 
pictures.  
You can login to ssh.ece.ubc.ca to run your simulations. If connecting via UBC wireless services 
or from home, on MobaXterm, you can start a new session: 
 → SSH 
 →Remote host: ssh.ece.ubc.ca      "specify username:" <your userID> 
 

http://sudip.ece.ubc.ca/cad-access/
http://mobaxterm.mobatek.net/
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Alternatively, you can use our dedicated compute server, ug-compute1.ece.ubc.ca, after going 
through the ssh.ece.ubc.ca gateway. To start such a new session: 
 → SSH 
 →Remote host: ug-compute1      "specify username:" <your userID> 
Connect through SSH gateway:  ssh.ece.ubc.ca        User: <your userID> 
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Linux (Ubuntu, Red hat, Mac) 
You can easily run Cadence without any extra GUI interface, you just open your terminal and type 
the following command to connect to ssh machines in ECE.  
>  ssh   -X   <userID>@ssh.ece.ubc.ca         # Note -X enables X11 forwarding and -x disables it. 
 
To jump directly to ug-compute1: 
 
> ssh -X -tt <userID>@ssh.ece.ubc.ca   ssh -X -tt <userID>@ug-compute1              # It will ask 
you for password twice. 
 
Mac Users: you need a version of X window system for your Mac, one of your options is XQuartz 
that you can find http://xquartz.macosforge.org/landing/. 
 
Connecting to Different Machines: 
If you are a graduate student and have your own computer in your research Lab, please ssh to 
your own computer using the above method to reduce the overload on the ECE machines. In 
order words, after connecting to ECE machines using one of the above method, use the following 
command to connect to your ssh machine. (Thanks) 
  
Command Prompt >>  ssh -X  [yourusername]@[your computer name] 
 

2.  Useful Linux commands to know for this course, known problems 
and solutions  

 
First of all, the machine ug-compute1 was deployed to allow students in ELEC404/571F to do 
their work, so please keep it private. 
 
"no more process", or "cannot fork" or your cadence is crashing : The number of processes per 
user is limited to 100. If you are receiving a message "no more process", or "cannot fork" or your 
cadence is crashing etc., you might have reached your limit.  
You can use the following command to check for the number of your processes: 
 
> ps aux |grep <your userID>  | wc -l            # this gives a count of the number of outputs from the 
PS command that are associated with your userID 
e.g. 
ssh-linux5:~> ps aux|grep q4t7|wc –l 
10                                                                    # this user could start 90 more processes 
 
> ps aux|grep <your userID> 
 
> ps aux | grep f0e7     # for example 
 
root      24071   0.0  0.0   70464  3220 ?        Ss   16:48   0:00  sshd: f0e7 [priv] 
f0e7     24074   0.0  0.0   70464  1648 ?        S    16:48    0:00  sshd: f0e7@notty 
f0e7     24075   0.0  0.0   12636  1300 ?        Ss   16:48    0:00 tcsh -c /usr/lib/openssh/sftp-server 
f0e7     24084   0.0  0.0   3904    748    ?        S    16:48    0:00  /usr/lib/openssh/sftp-server 
f0e7     31525   0.0  0.0   11880  428    ?        Ss   Feb13   0:00  ssh-agent 

http://xquartz.macosforge.org/landing/


4 
 

 
For example, the above jobs are created when you connect via Mobaxterm. 
In case the number of processes you are running is close to 100, you will have to close one or 
more or all applications so you can run any new commands. 
 
 
To kill a specific process use the command: 
 
> kill  <PID>                  # for example  24075  will kill the sftp-server which you only need when 
you are transferring files. 
 
To kill all your processes (which also logs you out) and start again: 
 
> pkill -u <userID>        # you can only kill your processes, for other IDs you will get a permission 
denied message 
 
 
File is locked. Cannot edit. Open for read only?  
Or upon starting Cadence, it takes a long time to startup, and then gives the warning: 
*WARNING* file /home/ugrad/(yourusernamehere)/CDS.log Connection refused  
Or it takes a long time to open a schematic:  
If you Cadence session crashed previously while a schematic was being edited, it left a lock file 
before the crash. [Cadence automatically creates this temporary lock file to prevent another user 
from opening up the same file for edit.] You will need to delete this lock file before editing the 
schematic again. Look for the file with an extension .cdslck and delete it.  

 

3.  Launching Cadence  
You need to make a directory where you can create your projects. Use the following commands to 
create the folder and change your current directory to the created folder. 
 

✓ [Creating the Folder] Command Prompt >> mkdir RFCourse2018 
✓ [Change Current Directory] Command Prompt >> cd RFCourse2018 

 
Now you are ready to run Cadence using the following commands.  
[Both undergraduate and graduate students should run Cadence using these commands for now 
(for homework assignment #1). Please do not share, distribute, upload any process 
information or design files outside the classroom because of strict confidentiality clauses.] 
 
 

✓ [Setting Up Environment for Cadence]  
 Command Prompt >> source /CMC/kits/AMSKIT616_GPDK/underg_install.csh 

 

 
You only need to run the above command once to set up the directory. After running the above 
command you will see a bunch of messages in your X2go/MobaXterm Terminal window. It will 
create some folders and generate a file setup_local.csh. Everytime you want to run Cadence 
source this file in the RFCourse2018 directory by typing: 
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Command Prompt >> source setup_local.csh 
 

Then, to open Cadence, descend into the cds folder by typing: 
 
Command Prompt >> cd cds 
 

and finally: 
 

✓ virtuoso  -log   virtuoso.log  &           # The  & will run the command in the background. So 
you can use your shell to give more commands. 

 
(To source Cadence using TSMC 65nm libraries, if you have access, use the command: 
 
 Command Prompt >> source /CMC/kits/tsmc_65nm/CRN65GP/PDKOA/kit.tsmc65nm_gp_OA.2.0.csh 
 

and then run the virtuoso command as normal) 
 
You should be able to see a GUI window pop up now; this windows is called CIW (Command 
Interpreter Window). If there is any error or warning message, this is the first place to take a 
look.  
 

 
 

 
 
 
 
 
In Cadence you have to first create a library (think of it as a container which includes different 
designs for your project). For this, start the Library Manager (Tools → Library Manager), then in 
the Library Manager window, File → New →Library: 
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Specify the Name of the Library (e.g. it could be RLC_Analysis). When prompted, select "Do not 
need process information".  
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[Later in the course, students may choose “Attach to an existing technology library” – which 
specifies that the library is going to use a specific technology, say, 45nm GPDK technology,  
gpdk045 , or, 65nm TSMC Technology, tsmcN65.] 
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After Creating Library, you have to create a Cellview; Cellview contains your designs. Click on 
“Assignments” in the Library Manager, then go to File → New → Cellview. 
In this window, type the Cell Name(e.g. RLC), and View Name (e.g. schematic) that specifies 
which view of the cell you are going to work on ( - for now we are working on the Schematic). 
Ensure that the Tool automatically chooses schematic as “Type”. For the application, choose Open 
with ADE L. Check “Always use this application for this type of file” if you want. [Sometimes, the 
software may upgrade you to ADE XL for license reasons].  
 

 

 
 
 
 
 
 
 
 
 
 
 
Below is the GUI of the Cadence Virtuoso Schematic Editor (bottom) as well as the Analog Design 
Environment (ADE) Editor (top). Let’s focus on the Schematic Editor first – this is the place 
where you are going to draw your schematic. 
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To draw schematics you need components, which you can add to your schematic as follow:  
Create → Instance. Or Just use the shortcut “i”. 
Let us add a resistance (res) from analogLib. Also, we will change the resistance to 50 Ohms from 
default of 1K Ohms.   
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Most of the components that you will be using in this course will be from analogLib library (some 
from “basic” library). If you don’t remember the name of the Library, Cell and View, you can click 
on Browse button and then find your component using Library Browser, which is shown below: 
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Your schematic will look like below after adding this resistor:  

 
Use the keys “[“ and “]” to zoom in and out.  

 



12 
 

For the RLC circuit, we also need an inductor, which can be added to your design either using 
Library Browser or by typing the Library Name (analogLib), Cell Name (ind) and View Name 
(symbol) in the corresponding boxes directly after using “i”. [Cell name for a capacitor is cap.] 
Choose 2.75nH for the inductance in our RLC circuit example. 

 
 
Schematic after adding the inductor: 
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Every electronic circuit needs a ground which will be considered as the reference point, 0 volt, 
for the potential.  Schematic after adding the ground symbol (gnd) from analogLib: 
 

 

 
 
 

 
Next, add a capacitor (cap) from analogLib with a value of 276.8fF.  
Finally, you need to apply an ac source (voltage “vsin” or current “isin”) to find the ac impedance 
of this circuit. As an illustration, we will use the current source component called isin with an AC 
magnitude of 1 A for simulation. Now you have to connect symbols using wire as follow [use the 
shortcut “w”]: 
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It is always good to label the nets that are important for your design because you can find them 
easily after the simulation in the results. We do the labeling as follow (Create → Wire Name… or 
shortcut “l”): 
Below we choose to add multiple wire labels in the GUI, and then click on the respective nets on 
the schematic in the proper sequence to label them. It saves some time compared to repeating 
the process for each net separately. 

 
 
Final schematic after adding the Labels is as follow.  
Don’t forget to check and save your design before any kind of simulation. Click on the floppy 
drive with check mark symbol on the top left corner, or just use the shortcut “shift+x”.  
 
 

 
 

 
 
Always look for warnings and errors in the CIW window and fix them. You may be able to ignore 
the warnings. In our example, we see no errors or warnings. 
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After clicking the check and save (shift+x) button and making sure that there is no errors and 
warning, we are ready to run the simulation using Analog Design Environment  
 

 
4. Running Simulation  
 
We want to run a frequency response to obtain the input impedance from 1MHz to 1000GHz. In 
order for this, in the Virtuoso Analog Design Environment, Choose Analyses → then click on ac 
bubble for Analysis and sweep Frequency from 1M to 1000G.  

 
 
After clicking Ok, your ADE window will look like below. Click on the green arrow to run 
simulation. If you get an error, go back and ensure that you “check and save”d the schematic! If 
everything is okay, the simulation should be successfully completed, and you will see the success 
notification on the CIW as well as “spectre.out” window.  
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5. Plotting Results   
 
Go to Results → Direct Plot → AC Magnitude in the ADE simulation window for choosing ac 
simulation. Next, go to your schematic editor to select the node “a” and hit <Escape> on your 
keyboard. You will then obtain a plot for the input impedance [Why?] of the RLC network. 
  
 
 

 


